Common issues :wrong motor direction,Endstop hit...

lkomnino
Posts: 0
Joined: Thu Feb 22, 2018 7:48 pm

Re: Common issues :wrong motor direction,Endstop hit...

Post by lkomnino » Tue Feb 27, 2018 3:09 am

As i can't edit a post that hasn't been uploaded yet.....

I was wrong about extruder not working, i plugged motor cable into extruder 2 port.

I put marlin 1.1.8, with geeetech 2560 confg.h file into it, to see if my mods were to blame.

No difference. So 99.999999999% sure it's a m/board issue.

User avatar
William
Site Admin
Posts: 6191
Joined: Tue Jun 07, 2016 9:38 am

Re: Common issues :wrong motor direction,Endstop hit...

Post by William » Tue Feb 27, 2018 10:42 am

I think you can swap the motor driver board A4988 of X axis and Y axis for a test
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

lkomnino
Posts: 0
Joined: Thu Feb 22, 2018 7:48 pm

Re: Common issues :wrong motor direction,Endstop hit...

Post by lkomnino » Tue Feb 27, 2018 7:01 pm

Already done, no difference.

Adz
Posts: 2
Joined: Sat Oct 21, 2017 1:29 pm

Re: Common issues :wrong motor direction,Endstop hit...

Post by Adz » Sat Jul 21, 2018 8:05 pm

thanks,
ive dusted off the duplicator 5 for rnd 2 and now i have the issue of x not returning home to the stopper... instead it fame bounces the opposite end..everything else is wrking fine...... any suggestions will be very much appreciated thanks

Gingko
Site Admin
Posts: 230
Joined: Tue Apr 24, 2018 10:43 am

Re: Common issues :wrong motor direction,Endstop hit...

Post by Gingko » Wed Jul 25, 2018 5:51 pm

Adz wrote:
Sat Jul 21, 2018 8:05 pm
thanks,
ive dusted off the duplicator 5 for rnd 2 and now i have the issue of x not returning home to the stopper... instead it fame bounces the opposite end..everything else is wrking fine...... any suggestions will be very much appreciated thanks
Hi, have you tried the method mentioned on page one of this post?
There are introductions of how to change the direction of motor.
Or you can check the user manual, the FAQ section.

Adz
Posts: 2
Joined: Sat Oct 21, 2017 1:29 pm

Re: Common issues :wrong motor direction,Endstop hit...

Post by Adz » Sat Jul 28, 2018 1:23 pm

thanks for ur reply m8.... im struggling to get how to change the code for the x axis.. it only travels home in the wrong direction.. other than that all is good.. i had read that stopper error could be the issue so i replaced it.. still the same issue.. returning home to the opposite end.. im not really a computer person so i may be missing something simple..

Gingko
Site Admin
Posts: 230
Joined: Tue Apr 24, 2018 10:43 am

Re: Common issues :wrong motor direction,Endstop hit...

Post by Gingko » Sat Jul 28, 2018 3:20 pm

Adz wrote:
Sat Jul 28, 2018 1:23 pm
thanks for ur reply m8.... im struggling to get how to change the code for the x axis.. it only travels home in the wrong direction.. other than that all is good.. i had read that stopper error could be the issue so i replaced it.. still the same issue.. returning home to the opposite end.. im not really a computer person so i may be missing something simple..
1, Firstly, you can download the firmware for D5 from here (NO.12):
viewtopic.php?f=20&t=17046

2, Download Arduino 1.0.1, and open the marlin.ino file with Arduino.
Go to configuration.h page.

3, Find out code: #define INVERT_X_DIR true // for Mendel set to false, for Orca set to true

4, Change the value to false, save the file, then install the firmware, refer to:
viewtopic.php?f=13&t=17181

Note: you might need to install the firmwar twice cause you don't know it is true or false in the first place.

Paleoberto
Posts: 1
Joined: Tue Jan 29, 2019 8:47 pm

Re: Common issues :wrong motor direction,Endstop hit...

Post by Paleoberto » Tue Jan 29, 2019 8:54 pm

Hello everyone

I recently bought a Geeetech I3 Pro, but I am having some issues that other users already had.
My X axis is moving on the wrong (right) side. I spent several time in the several discussions here trying to understand what and how to do, from installing driver to modifiy the firmware, and so on. In the Marlin - Configuration.h | Arduino 1.8.8, after modifying the direction of the X axis in Printer Settings in Repetier-Host, I finally got

Code: Select all

#define INVERT_X_DIR false    // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR true    // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR false     // for Mendel set to false, for Orca set to true
because, when I was trying to modify the "true" (original setting I found after installing the driver and checking the firmware) into "false" (what I wanted and want to do) alone in the firmware (thus, before seeing the option in Settings), the X axis was still moving in the wrong direction.
Now it does: from the control board, left equals to left, right to right.
HOWEVER, when I click Home X, it still goes to the wrong (right) direction! This thing is driving me crazy XD

What shall I do?
Thanks!

User avatar
William
Site Admin
Posts: 6191
Joined: Tue Jun 07, 2016 9:38 am

Re: Common issues :wrong motor direction,Endstop hit...

Post by William » Wed Feb 13, 2019 1:43 pm

Paleoberto wrote:
Tue Jan 29, 2019 8:54 pm
Hello everyone

I recently bought a Geeetech I3 Pro, but I am having some issues that other users already had.
My X axis is moving on the wrong (right) side. I spent several time in the several discussions here trying to understand what and how to do, from installing driver to modifiy the firmware, and so on. In the Marlin - Configuration.h | Arduino 1.8.8, after modifying the direction of the X axis in Printer Settings in Repetier-Host, I finally got

Code: Select all

#define INVERT_X_DIR false    // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR true    // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR false     // for Mendel set to false, for Orca set to true
because, when I was trying to modify the "true" (original setting I found after installing the driver and checking the firmware) into "false" (what I wanted and want to do) alone in the firmware (thus, before seeing the option in Settings), the X axis was still moving in the wrong direction.
Now it does: from the control board, left equals to left, right to right.
HOWEVER, when I click Home X, it still goes to the wrong (right) direction! This thing is driving me crazy XD

What shall I do?
Thanks!

I think you should check the EEPROM work or not.
Or you can try to invert the X home value to 1 instead -1.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Thastorino
Posts: 1
Joined: Tue Jul 14, 2020 2:34 am

Re: Common issues :wrong motor direction,Endstop hit...

Post by Thastorino » Tue Jul 14, 2020 2:40 am

Paleoberto wrote:
Tue Jan 29, 2019 8:54 pm
Hello everyone

I recently bought a Geeetech I3 Pro, but I am having some issues that other users already had.
My X axis is moving on the wrong (right) side. I spent several time in the several discussions here trying to understand what and how to do, from installing driver to modifiy the firmware, and so on. In the Marlin - Configuration.h | Arduino 1.8.8, after modifying the direction of the X axis in Printer Settings in Repetier-Host, I finally got

Code: Select all

#define INVERT_X_DIR false    // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR true    // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR false     // for Mendel set to false, for Orca set to true
because, when I was trying to modify the "true" (original setting I found after installing the driver and checking the firmware) into "false" (what I wanted and want to do) alone in the firmware (thus, before seeing the option in Settings), the X axis was still moving in the wrong direction.
Now it does: from the control board, left equals to left, right to right.
HOWEVER, when I click Home X, it still goes to the wrong (right) direction! This thing is driving me crazy XD

What shall I do?
Thanks!

Hi friend,

I just bought a A10T and had the same issue.. The problem was not there. The "define INVERT_E0_DIR" was set true.
Here is the code that solve my problem:

Code: Select all

// @section extruder

#define DISABLE_E false // For all extruders
#define DISABLE_INACTIVE_EXTRUDER true // Keep only the active extruder enabled.

// @section machine

// Invert the stepper direction. Change (or reverse the motor connector) if an axis goes the wrong way.
#define INVERT_X_DIR true
#define INVERT_Y_DIR true
#define INVERT_Z_DIR false

// @section extruder

// For direct drive extruder v9 set to true, for geared extruder set to false.
#define INVERT_E0_DIR false
#define INVERT_E1_DIR false
#define INVERT_E2_DIR false
#define INVERT_E3_DIR false
#define INVERT_E4_DIR false

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests